Microsoft Microsoft Excel

Excel Birden çok koşula dayalı olarak değerleri toplama

Belirli bir bölgedeki ürün satışlarının toplamı gibi birden fazla koşula sahip değerleri toplama gereği duyalım. Bu, bir formülde ÇOKETOPLA işlevini kullanmanın iyi bir durumu.

Şu örneğe iki koşulmız olan bu örneğe bakın: Güney bölgesindeki et satışları (sütun C ‘den) toplamını istiyoruz.

Excel çalışma sayfasındaki veriler

İşte bunu Acomplish için kullanabileceğiniz bir formül:

= ÇOKETOPLA (D2: D11, a2: A11, “Güney”, C2: C11, “et”)

Sonuç 14.719 değeridir.

Formülün her bir bölümüne daha yakından bakalim.

= ÇOKETOPLA, aritmetik bir formüldür. Bu örnekte, D sütununda bulunan sayıları hesaplar. İlk adım sayıların konumunu belirtmeli:

=ÇOKETOPLA(D2:D11,

Bir başka deyişle, formülün, bu sütunda olup koşulları karşılayan sayıları toplamasını istiyoruz. Bu hücre aralığı, bu formüldeki ilk bağımsız değişkendir -işlevin giriş olarak gerektirdiği ilk parça.

Ardından, iki koşulu karşılayan verileri bulmak için, işlevin verilerinin konumunu (a2: a11) ve koşulların ne olduğu (“Güney” olan) Ayrı bağımsız değişkenler arasındaki virgülleri fark edin:

=ÇOKETOPLA(D2:D11;A2:A11;”Güney”;

Tırnak işaretleri “Güney”

Son olarak, ikinci koşul için bağımsız değişkenleri, yani “et” sözcüğünü içeren hücre aralığını (C2:C11) ve Excel’in eşleştirebilmesi için sözcüğün kendisini (tırnaklar içinde) girin. Formülü kapanış paranteziyle sonlandırın ve ardından ENTER tuşuna basın. Sonuç olarak, 14.719.

=ÇOKETOPLA(D2:D11,A2:A11,”Güney”,C2:C11,”Et”)

Excel ‘de SUMıTOPLA işlevini yazdığınızda, bağımsız değişkenleri anımsamıyorsanız, yardım size hazırdır. = Topcıfsyazdıktan sonra, formülün altında, formül otomatik tamamlama

Formül otomatik tamamlama ve bağımsız değişken listesi resmine bakarak, Sum_Rangeörneğimizde, toplamak istediğiniz sayıların sütunu D2: D11; criteria_range1a2. A11, ölçüt1; “Güney” olan veri sütunudur.

ÇOKETOPLA işlevini girmek için Formülü Otomatik Tamamlama ipucunu kullanma

Siz yazarken, Formülü Otomatik Tamamlama’da bağımsız değişkenlerin kalanı da belirir (burada gösterilmemiştir); ölçüt_aralığı2 yani C2:C11, ölçüt2 yani “Et” ölçütünün bulunduğu veri sütunudur.

Formülü otomatik tamamlama ‘da topla ‘yı tıklatırsanız, daha fazla yardım sağlamak için makale açılır.

Bir deneyin

ÇOKETOPLA işleviyle denemeler yapmak istiyorsanız, işte bazı örnek veriler ve işlevi kullanan bir formül.

Burada, bu Web için Excel çalışma kitabında örnek verilerle ve formüllerle çalışabilirsiniz. Değerleri ve formülleri değiştirebilir veya kendi değerlerinizi ve formüllerinizi ekleyebilir ve sonuçların dinamik olara değişmesini görebilirsiniz.

Aşağıdaki tabloda yer alan tüm hücreleri kopyalayın ve Excel’de yeni bir çalışma sayfasında A1 hücresine yapıştırın. Formülleri daha iyi görebilmek için sütun genişliklerini ayarlayabilirsiniz.

BölgeSatış ElemanıTürSatışlar
GüneyItoİçecekler3571
BatıLanninSüt ürünleri3338
DoğuMakovecİçecekler5122
KuzeyMakovecSüt ürünleri6239
GüneyJordanSebze8677
GüneyLanninEt ürünleri450
GüneyLanninEt ürünleri7673
DoğuMakovecSebze664
KuzeyLanninÜrün1500
GüneyJordanEt ürünleri6596
FormülAçıklamaSonuç
‘ = Topla (D2: D11, a2: A11,
“Güney”, C2: C11, “et”)
Et satışlarını
toplar Güney
A sütunundaki bölge (Sonuç: 14719).
= ÇOKETOPLA (D2: D11, a2: a11
, “Güney”, C2: C11, “et”)

Notlar: 

  • Başka örnekler mi istiyorsunuz? Topketopla işlevinin makalesinde daha fazla bilgi bulabilirsiniz.
  • Başka bir aralık değerini temel alan tek bir aralık için toplam değer oluşturmak isterseniz, ETOPLA işlevini kullanın.

Yazar hakkında

Yüksel Güneş

Yorum Yap