Microsoft Microsoft Excel

Excel ÇAPRAZARA işlevi

DÜŞEYARA işlevi bir aralığı veya diziyi arar ve bulduğu ilk eşleşmeye karşılık gelen öğeyi döndürür. Eşleşme yoksa, DÜŞEYARA en yakın (yaklaşık) eşleşmeyi geri getirenin. 

=ÇAPRAZARA(aranan_değer, aranan_dizi, döndürülen_dizi, [bulunamadığında], [eşleştirme_modu], [arama_modu]) 

Bağımsız değişkenAçıklama
aranan_değerGerekli*Aranan değer

*Atlanırsa, DÜŞEYARA işlevi hücrede bulduğu boş lookup_array.   
aranan_diziGerekliAranan dizi veya aralık
return_arrayGerekliGeri dönecek dizi veya aralık
[if_not_found]İsteğe bağlıGeçerli bir eşleşme bulunamasa, tedarik if_not_found[ metnini girin.Geçerli bir eşleşme bulunamıyorsa ve [if_not_found] yoksa, #N/A döndürülür.
[match_mode]İsteğe bağlıEşleşme türünü belirtin:0 – Tam eşleşme. Hiçbiri bulunamıyorsa, #N/A. Varsayılan ayar budur.-1 – Tam eşleşme. Hiçbiri bulunamıyorsa, bir sonraki küçük öğeyi geri girin.1 – Tam eşleşme. Hiçbiri bulunamıyorsa, bir sonraki büyük öğeyi geri girin.2 – *, ?, ve ~ karakterlerinin özel anlamı olan joker karakter eşleşmesi.
[search_mode]İsteğe bağlıKullanmak üzere arama modunu belirtin:1 – İlk öğeden başlayarak bir arama gerçekleştirin. Varsayılan ayar budur.-1 – Son öğeden başlayarak ters arama gerçekleştirin.2 – Artan düzende sıralanmış lookup_array ikili arama gerçekleştirin. Sıralanmazsa, geçersiz sonuçlar döndürülür.-2 – Azalan düzende sıralanmış lookup_array ikili arama gerçekleştirin. Sıralanmazsa, geçersiz sonuçlar döndürülür.

Örnekler

Örnek 1,    aralıkta bir ülke adını aramak ve ardından telefon ülke kodunu vermek için DÜŞEYARA işlevini kullanır. Bu, lookup_value (F2 hücresi), lookup_array (B2:B11 aralığı) ve return_array (D2:D11 aralığı) bağımsız değişkenlerini içerir. Varsayılan olarak, DÜŞEYARA match_mode tam eşleşme ürettiği için bu bağımsız değişkeni içermez.Çalışan Kimliği'ne dayalı bir Çalışan Adı ve Bölümü vermek için kullanılan DÜŞEYARA işlevi örneği. Formül: =DÜŞEYARA(B2,B5:B14,C5:C14).

Not: DÜŞEYARA bir arama dizisi ve dönüş dizisi kullanırken, DÜŞEYARA tek bir tablo dizisi ve ardından bir sütun dizin numarası kullanır. Bu durumdaki eşdeğer DÜŞEYARA formülü şöyle olabilir: =DÜŞEYARA(F2,B2:D11,3,YANLIŞ)

———————————————————————————

Örnek 2,    çalışan bilgilerini çalışan kimlik numarasına göre okur. DÜŞEYARA’dan farklı olarak, DÜŞEYARA birden çok öğe içeren bir dizi döndürür, böylece tek bir formül C5:D14 hücrelerinden hem çalışan adını hem de departmanı döndürür.

Çalışan IDt'lerine dayalı bir Çalışan Adı ve Bölümü vermek için kullanılan DÜŞEYARA işlevi örneği. Formül: =DÜŞEYARA(B2,B5:B14,C5:D14,0,1)

———————————————————————————

Örnek 3,    önceki if_not_found bir bağımsız değişken ekler.

Bağımsız değişkeni olan Çalışan Kimliği'ne dayalı bir Çalışan Adı ve Bölümü vermek için kullanılan DÜŞEYARA işlevinin if_not_found. Formül: =DÜŞEYARA(B2,B5:B14,C5:D14,0,1,"Çalışan bulunamadı")

———————————————————————————

Örnek 4,    C sütununda E2 hücresine girilen kişisel geliri gösterir ve B sütununda eşleşen bir vergi oranı bulur. Hiçbir şey if_not_found0 (sıfır) olarak ayarlanır. Bağımsız match_mode1olarak ayarlanır; bu, işlevin tam eşleşmeyi araması ve bulamazsa bir sonraki büyük öğeyi geri döndürecek olmasıdır. Son olarak, search_mode bağımsız değişkeni 1olarak ayarlanır ve bu da işlev ilk öğeden son öğeye kadar arama yapmak anlamına gelir.

En yüksek gelire dayalı bir vergi oranı elde etmek için kullanılan DÜŞEYARA işlevinin resmi. Bu yaklaşık bir eşleşmedir. Formül: =DÜŞEYARA(E2,C2:C7,B2:B7,1,1)

Not: XARRAY’lookup_array sütun sütunu return_array, DÜŞEYARA ise yalnızca soldan sağa bakabilmektedir.

———————————————————————————

Örnek 5    hem dikey hem de yatay eşleşme gerçekleştirmek için iç içe ÇAPRAZARA işlevini kullanır. Önce B sütununda Brüt Kar’ı, ardından tablonun en üst satırı olan Çyr1’i (C5:F5 aralığı) ve son olarak da iki sütunun kesişim noktasındaki değeri döndürür. Bu, İnD ve EŞLE işlevlerinibirlikte kullanmaya benzer.

İpucu: YATAYARA işlevini değiştirmek için YATAYARA işlevini de kullanabilirsiniz.

2 XLOOKUP'u iç içe koyarak tablodan yatay veri dönmek için kullanılan DÜŞEYARA işlevinin resmi. Formül: =DÜŞEYARA(D2,$B 6:$B 17,DÜŞEYARA($C 3,$C 5:$G 5,$C 6:$G 17))

Not: D3:F3 hücrelerinde yer alan formül: =DÜŞEYARA(D2,$B 6:$B 17,DÜŞEYARA($C 3,$C 5:$G 5,$C 6:$G 17))

———————————————————————————

Örnek 6    topla işlevini ve ikiiç içe XLOOKUP işlevini kullanarak iki aralık arasındaki tüm değerlerin toplamını verir. Bu durumda, bağnazlar, muzlar için değerlerin toplamını almak ve ikisi arasında olan armutları da eklemek ediyoruz.

İki seçim arasında yer alan bir değer aralığının toplamını alan, DÜŞEYARA işlevini TOPLA ile kullanma

E3 hücresinde yer alan formül: =TOPLA(YATAYARA(B3,B6:B10,E6:E10):YATAYARA(C3,B6:B10,E6:E10))

Nasıl çalışır? DÜŞEYARA bir aralık döndürür, dolayısıyla hesaplaması geldiğinde formül şöyle olur: =TOPLA($E$7:$E$9). Bunun nasıl çalıştığını görmek için, buna benzer bir DÜŞEYARA formülü olan bir hücreyi seçin, ardından Formüller > Formül Denetleme > Formül Değerlendir’i seçin ve hesaplamanın adımlarını görmek için Değerlendir’i seçin.

Yazar hakkında

Yüksel Güneş

Yorum Yap